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Introduction: Overview 

Documentation: Statement of Ownership and Purpose 

To support Spectrum forms printing, Fiserv recommends the Minisoft® vendor. The information in this 
User Guide serves to elucidate Spectrum specific setup steps to get up and running with the Minisoft® 
eFORMz software product. Be aware that this User Guide contains information intended to be specific 
only to Spectrum users. Throughout this User Guide, the reader will be referred to Minisoft-owned and 
copyrighted documentation manuals for the primary routines and operations required to run and use the 
eFORMz product and its full feature set. The present User Guide in no way supersedes Minisoft-owned 
documentation, but is intended to serve merely to get Spectrum users up and running. 

Remain aware that the business processes employed and owned by Minisoft® remain at all times vendor-
specific and bear no relationship to Fiserv-owned products or business processes. Therefore this User 
Guide for Spectrum customers is for ready-reference and sample demonstration purposes only. You are 
always strongly advised to consult the vendor's own documentation and online help content when using 
the eFORMz product features and operations.  

Minisoft® documentation is available for download in PDF format here: 

http://support.minisoft.com/index.php/resources/manuals/ 

Fiserv recommends and assumes that you will use the following Minisoft® PDF documentation items to 
manage and produce your forms processing needs, whose information for the purposes of product 
representation supersedes all "utility" oriented information presented herein in the Spectrum Specific 
Setup User Guide for Minisoft eFORMz: 

 EFORMZ MANUAL [LATEST RELEASE NUMBER VERSION: Currently: eformzmanual_v10_05.pdf]  

 EFORMZ REFERENCE MANUAL [LATEST RELEASE NUMBER VERSION]  

 EFORMZ DIRECTOR [LATEST RELEASE NUMBER VERSION]  

Numerous Minisoft® owned and copyrighted quick training videos are also available from the link master 
page here: 

http://support.minisoft.com/index.php/resources/videos/ 

Including: : 

 What is eFORMz 

 eFORMz Highlights 

 eFORMz Install 

 Installing eFORMz on a Local Workstation 

 eFORMz Composer Tour 

 Creating a New Project with a Form Template 

 Parts 1, 2, and 3: New Project w/ the Document Template 

 Add a Font to eFORMz 

 Adding a Printer 

 Image From Project 

 Image From File Using a Variable 

 Image From a URL Using a Variable 

http://support.minisoft.com/index.php/resources/manuals/
http://support.minisoft.com/index.php/resources/videos/
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 What is eFORMz Conditional Logic? 

 Adding a Condition 

 New "Rule" eFORMz Project 

 Suppressing and Moving Input Data in the Composer 

 Forms Fill-In w/ Input Fields 

 Set Value Function 

 Left Trim and Right Trim Functions 

 Adding a Print Queued 

 Custom Form and Label Sizes 

 Custom Form and Label Sizes 

 Archiving Files with eFORMz 
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Spectrum Support for Minisoft eFORMz 

At the 2015.2.20 release level, Spectrum is enhanced for use with Minisoft® eFORMz. Specifically, we 
enhanced the pjetform internal Spectrum program so that it is now possible to determine what software 
package to use in order to generate the final output for the printer (PCL format). 

Now when a form contains an ".EFZ" extension in its file name, we use the Minisoft® eFORMz package 
instead of the formerly used Adobe Print Agent to create the printer output. 

The existing pjetform Spectrum internal program has up to now been used to print JetForm documents. 
JetForm documents have allowed financial institutions utilizing the Spectrum Electronic Forms Module 
(#100) and the JetForm Design tool to print their own custom forms and letters to printers on their local 
area network. 

Moving forward from Spectrum Release 2015.2.20, the eFORMz solution from Minisoft® replaces the 
JetForm product for use with Spectrum. eFORMz has an executable that runs on the HPUX system. 
eFORMz includes a Form Designer (eFORMz Composer) that runs on a Windows Desktop. Minisoft will 
assist users in migrating away from the JetForm product by providing a conversion tool for existing IFD 
files. 

General Operations Notes Regarding Migration Planning:  

 The eFORMz executable is not included in the Spectrum distribution. It must be downloaded to a PC 
that has access to the host and is easily installed from there.  

 Once clients purchase the eFORMz product, it is possible to convert existing IFD files, or, alternatively, 
engage the eFORMz Composer solution to perform this task.  

 EFORMZ DIRECTOR [LATEST RELEASE NUMBER VERSION] 

 Migration can be effected on a form-by-form basis. No requirement exists to convert all forms at one 
time. 

 Adobe Central vendor support ends in June 2016; however, it will not cease to function on the sunset 
date. 
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Spectrum-Specific Installation Instructions 

 

Important:  In conjunction with your use of this User Guide for Spectrum-specific process 

advice and tips, you must at all times refer to the Minisoft®-owned documentation as the 

authoritative product guide for eFORMz processes. Currently, this document 

(eformzmanual_v10_05.pdf) covers the eFORMz Client Install process in its "eFORMz Client 

Install" section. The Host/Server Unix Environment Install process is covered in its "Unix 

Environment Install" section. To the extent that Spectrum-specific Installation requirements and 

advice applies, we provide the additional process instruction in the "Spectrum Specific Setup 

User Guide for Minisoft® eFORMz". 

Spectrum-Specific eModifile Setup to Enable eFORMz 

The primary change you are required to make in Spectrum eModifile as a pre-requisite to enable 
eFORMz operation is as follows: 

In eModifile, navigate to: 

eModifile, Main Menu, DFILES Database File Maintenance, DFILES D-H Maintenance Categories > 
EF Cross Reference Maintenance 

and adjust these data elements as necessary: 

Form Name 

Device Number 

RBPNNRE.EFZ 

On the Spectrum Front Office side, you simply need to specify the form: 

DOCUMENT:RBPNNRE 

Be aware that the DFI Output remains the same as was previously the case. 

Operation: Simply launch the the Minisoft® application in order to print the output.  

Spectrum Operations Tip:  A configuration file exists in FI data. This configuration file is 

optional; however, it does allow you to specify additional command line options for the 

Minisoft® utility. 
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eFORMz Client Install (Windows PC Installation) 

The eFORMz install contains all the necessary components for installing eFORMz on the client and host 
systems. To install on a host system you must first install eFORMz on a client work station (Windows) and 
then proceed with installation to a host system. To install on the host systems you will utilize the eFORMz 
Composer client utility. The following instructions will explain how to install the client and host system 
installs. 

From the location provided in the Minisoft® website for Fiserv customers (www.minisoft.com), register 
and download the latest eFORMz install package. 

Once the setup file has been downloaded: 

Double-click the eFORMz executable (eFORMz_full.exe) and follow the on-screen instructions. The 
default install directory is here: 

C:\Minisoft\eFORMz_6\ 

Q: Michael to Team: What about the HPUX server license acquisition issues? How / when is this to be 
addressed? 

You will be asked for a password. Contact your appropriate source to obtain the password. Typically, you 
must complete a registration page, after which you can expect to receive a call back with your password. 
Otherwise, a specific portion of the Minisoft® website provided for Fiserv customers will make available a 
Fiserv-wide password.  
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Unix HPUX Environment Install (Host / Server Installation) 

The following instructions assume you have already installed eFORMz on your Windows PC client 
system. The eFORMz Composer will be used to install the needed components on your Unix system. 

From your host machine login as Administrator (root), create the following directory: 

mkdir minisoft 

Change the attributes of the minisoft directory to the following: 

chmod 755 minisoft 

Open the eFORMz Composer on your Windows PC client desktop. 

To do this, start the eFORMz Composer from your Windows Start menu by selecting Programs > 
eFORMz [Version Number] > eFORMz Composer. The eFORMz Composer application will open. Once 
it does, now select the Host Tools menu. To do this, navigate as follows from the top eFORMz menu: 
Host Tools > Unix > Install eFORMz. 

The Unix Login pop-up dialog appears. 

 

From this dialog: 

Enter your Host Address (IP). 

Enter the Host Port. 

Ensure the Host Type is "Automatically Detect". 

Enter the User Name. (Note: Ensure that you Use a User Name for an individual who is going to be 
permitted to access the destination directory.) 

Enter the Password. 

Assuming you are using a Secure Shell account, check the "Use SSH" check-box and identify the Known 
Hosts File if necessary. 

Click the Connect button. 

The Unix Install dialog box appears. 
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In the Unix Install dialog, by default the Install from selection field displays the \minisofteFORMz_6 
location as the directory from which eFORMz is to select the installation files. Note: The default install 
directory on your host system is the minisoft directory under root. 

For the Install to input field, you must install to the specific Instance of Spectrum that you have, but 
ensure that you add /minisoft to the end of the string in this input field. For example:  

/var/summit/spectrum/TEST/minisoft 

Select the Clear remote "jars" subfolder before copy" checkbox. 

Select the "include local "fonts" subfolder in copy" checkbox. 

Click OK to complete the installation process. The Progress dialog box appears. When the installation is 
complete, you are returned to the eFORMz Composer main window. 

Recommended Best Practice: 

We highly recommend that you install the Minisoft® product once for each HPUX Instance. This works to 
simplify potential permissions and file access issues. 

Once the eFORMz software has been installed on the designated form designer’s Windows PC client, 
and the engine on the HPUX server has also been installed, you can begin the process of converting 
individual forms. 

Operations Setup Note: 

For all information on setting up and configuring printers, please reference the Minisoft® EFORMZ 
MANUAL [LATEST RELEASE NUMBER VERSION: Currently: eformzmanual_v10_05.pdf].  



Spectrum 

Forms Migration Process: With Reference to Spectrum  Fiserv 

Spectrum-Specific Setup User Guide for Minisoft eFORMz Support  11 
November 2015/1.0  

Forms Migration Process: With Reference to Spectrum 

The eFORMz Composer allows you to build, maintain, and manage an eFORMz project file. A single 
eFORMz project file can contain any number of forms, variables, and rules. Each project can contain a 
number of Logical Pages, with each page containing a number of Forms. Forms can be created 
dynamically within eFORMz or using a preferred word processor, desktop publishing, or drawing 
package. 

Each form can contain a number of Rules. Rules are used to alter the appearance of data that is 
displayed on the form. Rules provide you with the options of changing font size and style, moving data, 
converting ASCII characters to barcodes, and more. 

The vast majority of projects will only have one logical page even though the actual print job may contain 
several physical pages. For example, if you are creating a payroll print job for your company that consists 
of 5 employees and the payroll print job simply prints one check after another, this would be considered a 
single page project.  

 

Please reference the Minisoft® EFORMZ MANUAL [LATEST RELEASE NUMBER VERSION: Currently: 
eformzmanual_v10_05.pdf] for detailed information about eFORMz Components, Printer 
Recommendations, eFORMz Composer, Creating an eFORMz Project File, Form Overlay, eFORMz 
Composer Data Customization, and Alternate Form Template Creation. 
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Migration Process 

Start the eFORMz Composer from your eFORMz Start menu by selecting Programs > eFORMz 10 > 
eFORMz Composer. The eFORMz Composer application launches. 

In the Composer, navigate to: File > Open Project > Open (Look in: Projects). 

The Open dialog box appears. From the Look in field, navigate to the following directory: 

C:\Minisoft\eFORMz\Projects\ 

Be aware that eFORMz uses an IFD (Form Definition). To clarify: the IFD is the Form Definition, not the 
data file. 

Convert the IFD to EFZ using the eFORMz desktop application. 

To do this: 

Select an IFD file: JetForm IFD Files (for example: RBPNNRE.DAT). 

The file opens in eFORMz Composer and you can view the structure (project file layout) of the project. 

The Spectrum output is thus able to be converted to an XML tree. 

Note that the names that appear come from the IDF file. When the data is read in from the IFD file, the 
result is shown on the right side of the screen in the Composer's Viewer pane. The Viewer pane shows 
the record data as laid out in the structure itself. 

Save the project on your Windows PC client workstation (example: a "RBPNNRE" file). 

Note: 

From this point the IFD file is no longer relevant or in use. You are using the EFZ only! Ensure that you 
update the EF cross reference to use the EFZ form instead of the MDF form. 

Move the EFZ file to the HPUX system via the eFORMz desktop application: 

To do this, use the Unix Login dialog to save the file to the HPUX host server for execution, to a location 
such as this, for example: 

/var/summit/spectrum/TEST/EFZ 

Note: 

You likely will need to create the "EFZ" directory yourself. 

To save a project file to your Unix HPUX host server system: 

From the eFORMz Composer, open the project you would like to upload to the Unix host machine (File > 
Open Project). 

Once the project file has been opened, select Host Tools > Unix > Save Project. 

The Unix Login dialog box displays. Enter your Host IP Address, user name, and password and then 
click Connect. 
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The Save dialog box will display. Enter the name you would like the project to have on the Unix system in 
the File Name field. By default the project path is the minisoft directory under root. Click Save. 

 

Operations Note: 

After the transfer of the project file to the host system, a change to the attributes of the project file must 
take place. From your host machine, do this: 

Logon as Administrator (root). 

Change the directory to minisoft. 

From the minisoft directory change the attributes of the project file: 

chmod 755 {project name}.efz 

Note that you will also need to do the above attribute change once you have created the command file 
and transferred it to the host system. 

Once the save is complete, you are returned to the eFORMz Composer.  

Operations Tip: 

Ensure that you retain the original copy of your project on your Windows PC client workstation. It is not 
recommended that you obtain the files off of the HPUX host server, nor should you edit the files on the 
host. Instead, you should, as the forms designed, make a copy locally on the Windows PC client- only to 
move it to the HPUX host server when you are finished designing. 

A project file can, however, be opened from the Unix system. To do so, do this: 

From the eFORMz Composer select Host Tools > Unix > Open Project. Login using your user name 
and password and click Connect. 

Select the directory where your project file is located and select the project file you would like to open. 

Click Open. Your project file appears in the eFORMz Composer. Make the necessary changes and then 
select Host Tools > Unix > Save Project to save your project file back to the Unix system. 
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Forms Migration and Processing: Known Issues 

PCX Image File Handling 

Be aware that references in the DFI to PCX images will not function. This is due to the fact that PCX 
image files are not supported by eFORMz: 

PICTURE=*.PCX 

You must convert your graphics files to another format. You can use your preferred third-party graphics 
conversion utility tool to accomplish this. It is assumed that you will change the images to .JPG images. 

You can modify the EFZ document to pull an image from the location where the PCX image once was. 

To do this: 

Locate and identify the picture. 

Place the picture. 

Deactivate the "place text" feature. 

Add "Load image from file". (Use the LoadImage Action dialog to do this.) Note that you can also use 
the Load from: Use file from Rule variable. 

Update the name of the PCX file on the DFI form or change it. 

Finally, you need to move the location where the image is to be printed. 

Font Handling 

It is possible that -should you be using a font which is not a resident HP font- you may encounter the 
need for a few configuration changes. You can open an existing default file in the Minisoft installation 
directory called "eFORMzCfg.xml" in order to define character sets (which is useful for translation) and to 
define fonts. 

Field Length and Positioning 

In rare instances, the length of a converted form field may not be quite precise enough, causing elements 
to wrap where they ought not to. You can change the Width in the Paragraph Properties dialog from the 
Composer.  

 


