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Disclaimer
The information contained in this document is subject to change without notice.

Minisoft, Inc. makes no warranty of any kind with regard to this material, including, but not limited 
to, the implied warranties of merchantability and fitness for a particular purpose. Minisoft, Inc. or its 
agents shall not be liable for errors contained herein or for incidental or consequential damages in 
connection with the furnishings, performance, or use of this material.

This document contains proprietary information which is protected by copyright. All rights are 
reserved. No part of this document may be photocopied, reproduced, or translated to another pro-
gramming language without the prior written consent of Minisoft, Inc.

 ©2014 by Minisoft, Inc. Printed in U.S.A.

 eDIRECT PLUS Version 10 - January 2014 
 

All product names and services identified in this document are trademarks or registered trademarks 
of their respective companies and are used throughout this document in editorial fashion only and 
are not intended to convey an endorsement or other affiliation with Minisoft, Inc.
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License Agreement
READ CAREFULLY BEFORE INSTALLING THE MINISOFT SOFTWARE APPLICATION:
CUSTOMER: THE MINISOFT SOFTWARE APPLICATION (“PRODUCT”) THAT YOU PURCHASED CONTAINS COPYRIGHTS, TRADE SECRETS, TRADE MARKS, AND 
OTHER INTELLECTUAL PROPERTY RIGHTS BELONGING TO MINISOFT, INC. (“MINISOFT”), HAVING ITS PRINCIPAL OFFICES LOCATED AT 1024 FIRST STREET, 
SNOHOMISH, WASHINGTON, 98290, U.S.A. THE PRODUCT MAY BE INSTALLED, COPIED, DISPLAYED, EXECUTED, PERFORMED, OR USED IN ANY OTHER FASHION 
ONLY IN ACCORDANCE WITH THE TERMS OF THIS LICENSE AGREEMENT (“AGREEMENT” OR “LICENSE”). THE TERMS “YOU” OR “YOURS” ARE SOMETIMES USED 
HEREIN AND MEAN RESPECTIVELY CUSTOMER OR CUSTOMER’S. 
SOMETIMES EACH OF MINISOFT AND CUSTOMER IS REFERRED TO HEREIN AS A “PARTY,” AND SOMETIMES THEY ARE COLLECTIVELY REFERRED TO AS THE 
“PARTIES.”
YOU MAY NOT INSTALL, COPY, DISPLAY, EXECUTE, PERFORM OR USE IN ANY OTHER FASHION THE PRODUCT EXCEPT IN ACCORDANCE WITH THE TERMS AND 
CONDITIONS OF THIS AGREEMENT. IF YOU INSTALL, COPY, DISPLAY, EXECUTE, PERFORM OR OTHERWISE USE ANY PART OF THE PRODUCT, YOU ARE DEEMED 
TO HAVE ACCEPTED AND YOU ARE BOUND BY ALL THE TERMS AND CONDITIONS OF THIS MINISOFT LICENSE AGREEMENT (“AGREEMENT”). IN ORDER TO USE 
THE PRODUCT, YOU MAY BE REQUIRED TO OBTAIN A UNIQUE CODE OR CODES FROM MINISOFT TO ENABLE INSTALLATION, COPYING, DISPLAY, EXECUTION, 
PERFORMANCE AND OTHER USE OF THE SOFTWARE PRODUCT.
IF YOU DO NOT ACCEPT AND AGREE TO THE TERMS AND CONDITIONS OF THIS AGREEMENT, YOU ARE PROHIBITED FROM INSTALLING, COPYING, DISPLAYING, 
EXECUTING, PERFORMING, OR USING IN ANY OTHER FASHION THE PRODUCT. VIOLATION OF THIS AGREEMENT (1) CONSTITUTES INFRINGEMENT, MISAPPRO-
PRIATION AND CONVERSION OF MINISOFT’S COPYRIGHTS, TRADE SECRETS, AND OTHER INTELLECTUAL PROPERTY RIGHTS, (2) WILL SUBJECT THE INFRINGER 
TO SIGNIFICANT CIVIL LIABILITIES FOR DAMAGES (INCLUDING WITHOUT LIMITATION STATUTORY DAMAGES) AND OTHER REMEDIES AND LIABILITIES, AND (3) 
MAY CONSTITUTE VIOLATION OF CRIMINAL LAWS.
IF A CUSTOMER IS PURCHASING AN UPGRADE FOR AN EARLIER VERSION OF THE PRODUCT, THEN THIS AGREEMENT SHALL SUPERSEDE THE TERMS AND CON-
DITIONS OF THE LICENSE AGREEMENT THAT APPLIED TO THE EARLIER VERSION AS TO THE USE OF THE UPGRADE PRODUCT AS OF THE DATE OF INSTALLATION 
OF THE UPGRADE.
NOW, THEREFORE, in consideration of the foregoing provisions and the terms and conditions herein contained and for other good and valuable consideration, the 
receipt and sufficiency of which are hereby acknowledged, the following terms and conditions apply:
A. License Grants
1. Upon MINISOFT’s receipt from the Customer of the one-time license fee and further subject to the other terms and conditions herein, MINISOFT grants the Customer 
a non-exclusive and non-transferable perpetual license: (a) to install and use the Product on only one host computer or business server in the Customer’s business 
organization; and (b) to install the client portion of the Product on a network server for access by more than one personal computer and on any personal computer client 
accessing the host server program. 
2. You may not: (a) allow access to or use of the Product to anyone outside of your organization; (b) decompile, reverse engineer, decrypt, disassemble, or otherwise 
attempt to copy or replicate the source code; (c) modify or translate those portions of the Product that are provided in an object or source code form, or alter, merge, 
modify, reverse engineer or adapt the Product in any way including disassembling or decompiling; (d) copy, loan, rent, lease or sublicense, assign, convey, sell, mort-
gage, pledge, dispose or in any other manner transfer to a third-party any part of or all of the Customer’s rights and obligations under this Agreement or in the Product; 
or (e) otherwise copy, distribute, rent, loan, disseminate, publish, sell or transfer any portion of the Product in any way inconsistent with or contrary to the terms and 
conditions of the Agreement. 
3. Any attempt to violate any prohibitions described in this Agreement shall be considered a material breach of this Agreement, and no attempt to violate section 2(c) or 
2(d) in the immediately preceding paragraph shall have any effect, and any prohibited act described therein shall be void and of effect if made by the Customer.
4. You may make one copy of the Product for use as a backup copy (the “Copy”) provided that: (i) the Copy includes all notices of copyright and all other proprietary 
rights appearing in and on the Software Product; (ii) the Copy and the original Product are not in use at the SAME time; (iii) Customer establishes a procedure for ac-
counting for the Copy at all times; and (iv) Customer destroys or returns to MINISOFT the Copy when it is no longer required or when the license grants made hereunder 
are terminated for any reason, whichever occurs first.
5. This Agreement grants to the Customer a license for use of the Product on the terms and conditions set forth in this Agreement; and (ii) the Customer may not install, 
copy, perform, execute, display, or use in any other fashion the Product except in accordance with the terms and conditions of this Agreement. By any use of any ele-
ment of the Product, the Customer shall be deemed to have accepted and be bound by all the terms and conditions of this Agreement.
6. MINISOFT retains and reserves all rights to the Product. Nothing contained herein shall be deemed to convey to the Customer any title to, or an ownership interest 
in, the Product or any of the intellectual property rights contained in the Product. Upon termination of this Agreement, all rights granted to the Customer herein shall 
automatically revert to MINISOFT.
B. Termination
The license grants made hereunder shall automatically terminate on the date of any breach by the Customer of any of the terms and conditions of this Agreement. In 
any such termination, you shall discontinue using the Product. You further agree to return the Product to MINISOFT or destroy all components of the Product and to 
certify in writing that the Product is no longer in use and that you have kept no copies of the Product. In any such termination of the license grants, none of MINISOFT’s 
rights in law or equity shall be barred, discharged, released, or otherwise impaired by such termination, and MINISOFT reserves all such rights described herein.
C. Confidential Information
The Product also contains MINISOFT’s commercially valuable, proprietary and confidential information and trade secrets (collectively “Confidential Information”). 
You are obligated to preserve and hold in confidence any Confidential Information and may not use any of it except in accordance with the terms and conditions of 
this Agreement. Confidential Information shall not include what is already public at the date of its disclosure or what later becomes lawfully public through no fault or 
responsibility of the Customer.
D. Limited Warranties and Limitations on Damages and Remedies.
1. Only the limited warranties expressly described in this section are made to the Customer purchasing this Product. No warranty of any kind, whether express or 
implied, is made to any third-party or other transferee or successor of the Customer.
2. MINISOFT warrants that it has the right to grant the licenses contained in this Agreement.
3. MINISOFT warrants that this product will execute its programming instructions when properly installed on a properly configured computer for which it is intended. 
MINISOFT makes no warranty of any kind, implied or express, that the Product will meet Customer’s requirements or that the Product will be uninterrupted or error-free
4. MINISOFT, Inc. warrants the media upon which this Product is recorded to be free from defects in materials and workmanship under normal use for a period of 90 
days from the date of purchase. During the warranty period MINISOFT will replace media that prove to be defective. Customer’s exclusive remedy for any media that 
proves to be defective shall be to return the media to MINISOFT for replacement.
5. MINISOFT’ only obligation, liability and/or remedy, with respect to the warranties set forth in this Agreement shall be one of the following, which MINISOFT shall 
have sole discretion to choose: (1) as described above, to provide replacement media (whether in the form of the current release or otherwise) for the Product; (2) to 
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replace, without charge, the Product with a functionally equivalent software product; or (3) to refund the applicable license fees paid to MINISOFT by Customer. These 
are the sole and exclusive remedies for any breach of warranty.
6. MINISOFT shall have no obligation, liability or any other kind of responsibility for the costs of restoring any destroyed or defective data, installation of replacement 
media, or software conversion work made necessary by replacement media, even if MINISOFT had been specifically informed by Customer of the possibility or probabil-
ity of any such consequences. During the ninety (90) days warranty period for the media, MINISOFT will replace, without charge, on an exchange basis, any media which 
is not as warranted. Customer must return the defective item postpaid to MINISOFT, postmarked within the time period stated above. Customer must either insure the 
defective item being returned or assume the risk of loss or damage in transit. Any claim under the above warranty must include a copy of Customer’s receipt or invoice 
or other proof of the date of delivery.
7. Year 2000 Warranty. MINISOFT warrants that the Product will accurately process date/time data (including, but not limited to, calculating, comparing, and sequenc-
ing) from, into, and between the twentieth and twenty-first centuries, and the years 1999 and 2000 and leap year calculations, in accordance with the Product’s docu-
mentation BUT ONLY to the extent that other technology and systems (e.g., software and operating systems, hardware and firmware) used in combination with the 
Product properly exchanges date/time data with it. In addition to the limitations of liability and remedies described above in this Section, the Year 2000 warranty made 
herein is made only for ninety (90) days after the date of delivery of the Product and only if any noncompliance is discovered and made known to MINISOFT in writing 
within such ninety (90) days. The Year 2000 warranty expires after such ninety (90) day period and shall not extend to any events occurring after the expiration date. 
8. MINISOFT makes no other warranty, expressed or implied, with respect to the Product. 
9. NOTICE: THE WARRANTIES, OBLIGATIONS AND LIABILITY OF MINISOFT AND THE RIGHTS AND REMEDIES OF CUSTOMER SPECIFICALLY SET FORTH IN THIS 
AGREEMENT ARE THE CUSTOMER’S EXCLUSIVE REMEDIES. MINISOFT DISCLAIMS, AND CUSTOMER HEREBY WAIVES, DISCHARGES AND RELEASES MINISOFT, 
ITS OFFICERS, DIRECTORS, EMPLOYEES AND AGENTS, FROM ANY AND ALL (1) OTHER WARRANTIES, OBLIGATIONS, OR LIABILITIES AND (2) RIGHTS, CLAIMS, 
CAUSES OF ACTIONS, EXPRESS OR IMPLIED, ARISING BY LAW OR OTHERWISE IN CONNECTION WITH, REGARDING, OR ARISING FROM THE PRODUCT OR ANY 
RELATED SOFTWARE, TANGIBLE OR INTANGIBLE ITEMS OR SERVICES PROVIDED UNDER THE AGREEMENT (INCLUDING, WITHOUT LIMITATION, ALL DOCU-
MENTATION SUPPLIED WITH THE PRODUCT). THE WAIVER, DISCHARGE AND RELEASE INCLUDE, BUT ARE NOT LIMITED TO: (1) ANY IMPLIED WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A SPECIFIC PURPOSE; (2) ANY IMPLIED WARRANTY ARISING FROM COURSE OF PERFORMANCE, COURSE OF DEALING, OR 
USAGE OF TRADE; AND (3) ANY OBLIGATION, LIABILITY, RIGHT, CLAIM, OR REMEDY, WHETHER IN TORT, CONTRACT, OR OTHERWISE. IN NO CASE SHALL MINI-
SOFT BE LIABLE FOR ANY INCIDENTAL, INDIRECT, SPECIAL, CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, LOSS OF USE, REVENUE, PROFIT, 
OR DATA), PUNITIVE DAMAGES, EXEMPLARY OR OTHER STATUTORY DAMAGES, EXPENSES, COSTS (INCLUDING ATTORNEY FEES). IN ADDITION, IN NO CASE 
SHALL MINISOFT’S LIABILITY EXCEED THE FEES PAID BY CUSTOMER FOR THE PRODUCT.
E. Updates
Customer is entitled to updates and enhancements to licensed software if under a current Minisoft software update and subscription service. The cost of the update and 
subscription service will be 20% of the purchase price of the licensed software. The update and subscription service is for twelve (12) months and can be renewed at the 
customer’s discretion. 
F. Support Services
A customer that has purchased annual support entitles them to any and all software updates for their licensed product(s) as well as technical support via phone and 
email. Software Updates are available from our web site, www.minisoft.com. Included with the purchase of support is the use of our Toll Free 800 number, and support 
email. Days and Hours of support coverage are Monday through Friday 7:30am (Pacific) until 5:00pm (Pacific).  When support is purchased or renewed, an update may 
be downloaded from the Minisoft Website. In cases where support has expired, back-support is charged to bring the support account current. Any supplemental soft-
ware code provided to you as part of the Support Services shall be considered part of the SOFTWARE PRODUCT and subject to the terms and conditions of this License 
Agreement. 

G. Miscellaneous
1. Governing Law. This Agreement is made for the sole benefit of the parties hereto, and there are no third party beneficiaries to this Agreement. This Agreement shall 
be interpreted under the laws of the State of Washington, notwithstanding the application of any jurisdiction’s choice-of-law rules to the contrary.
2. Independent Contractors. No agency, partnership, joint venture, or employer-employee relationship is created hereby, and neither party nor any of its agents or 
employees shall have any authority of any kind to bind the other party in any respect whatsoever. Each party is an independent contractor to the other party.
3. No Assignment by Customer. This Agreement shall be binding upon and inure to the benefit of MINISOFT and any successors and assigns. Customer shall have no 
right to assign or otherwise transfer its rights or obligations under this Agreement except with the prior written consent of MINISOFT, which MINISOFT in its sole discre-
tion and for any reason or no reason provide or withhold.
4. Entire Agreement. This Agreement contains the complete understanding between the parties and shall as of the date the Product is first installed supersede all other 
agreements, whether they are written or oral, between the parties concerning the particular subject matter. The language of this Agreement shall for all purposes be 
construed as a whole, according to its fair meaning, not strictly for or against either party, and without regard to the identity or status of any person who drafted all or 
any part of it. No purchase order or any other purchasing instruments issued by Customer, even if such purchase order or other purchasing instrument provides that 
it takes precedence over any other agreement between the parties, shall be effective to contradict, modify, delete from or add to the terms of this agreement in any 
manner whatsoever.
5. Severability. In the event that any one or more provisions of this Agreement is found by a court of competent jurisdiction to be unenforceable or invalid, then notwith-
standing any such finding the remainder of this Agreement shall remain in full force and effect, and such provision that is found to be unenforceable or invalid shall be 
deemed severed. 
6. Waiver. Neither party’s right to require performance of the other party’s obligations hereunder shall be affected by any previous waiver, forbearance, or course of 
dealing, nor shall any waiver or forbearance or other course of dealing at any time with respect to any term or condition in this Agreement be effective unless evidenced 
in writing signed by the waiving party as to such waiver, forbearance or other course of dealing. No waiver or modification of this Agreement or any covenant, condition 
or limitation herein contained shall be valid and no evidence of waiver or modification shall be offered or received in evidence in any proceeding, arbitration or litigation 
between the parties hereto arising out of or affecting this Agreement or the rights or obligations of the parties hereunder, unless such waiver or modification is in writing 
duly signed by both parties.
7. Headings, Sections - The various headings in this Agreement are inserted for convenience only and shall not affect the meaning or interpretation of this Agreement or 
any Section or provision hereof.
8. Disputes; jurisdiction and venue. Customer and MINISOFT consent to personal jurisdiction, subject matter jurisdiction, and venue in the state and/or federal courts 
sitting in King or Snohomish Counties, State of Washington. Any action relating to this Agreement must be brought in the state or federal courts located in King or 
Snohomish County, Washington.
9. Attorney’s Fees. In the event legal action is brought by either party to enforce any of the provisions of this Agreement, the prevailing party shall recover its reasonable 
attorney’s fees, costs, and expenses, including but not limited to fees, costs and expenses of collecting any judgment.
10. Export. The export of this product is restricted by U.S. export regulations.
11. GOVERNMENT RESTRICTED RIGHTS. The Software Product and documentation are provided with restricted rights. Use, duplication or disclosure by the Govern-
ment is subject to restrictions as set forth in subparagraph (c) (2) (ii) of the Rights in Technical Data and Computer Software clause at DFARS 252. 227-7013 or subpara-
graphs (c) (1) and (2) of the Commercial Computer Software-Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/manufacturer is MINISOFT, INC., 1024 
FIRST STREET, SNOHOMISH, WASHINGTON, 98290, U.S.A
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eDIRECT
Introduction to eDIRECT

eDIRECT is a processing module of eFORMz that allows you to output your merged 
reports to multiple destinations or output types simultaneously, including:

♦	 Print (Print File)

♦	 E-Mail

♦ Fax

♦ HTML Email output (eDIRECT PLUS)

♦			 Database (eDIRECT PLUS)

♦ Archive (eDIRECT PLUS)

♦ SMS (eDIRECT PLUS)

NOTE:  In the Demo version of eFORMz, eDIRECT PLUS is automatically 
enabled. However, once the product is licensed, the eDIRECT PLUS tab 
will only display if it has been purchased. 

Each output type is symbolized by one of the following icons:

Print (Print File)
Output is directed to a printer or as a file to a specified directory. Print file 
output types include pdf, efd, pcl, text, and html. 

E-Mail
Output is directed to an email server with the ability to attach pdf, efd, pcl, 
text, or html file output.

Fax
Output is directed to a fax server which faxes your output to the specified fax 
number. 

eFORMz will automatically create a Print File, E-Mail or Fax destination folder in the 
base directory that the process is executed from for user manageability.

Each output type can contain single or multiple conditions:

Conditions 
Defines a condition.
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Each output type has multiple elements that are defined with the following symbols:

Print Element 
Element that signifies output to a specific printer device.

Generated Element 
Element that contains generated content. The type of content is shown after 
the element name. 

Constant Element 
Element that has a constant value. The type of content is shown after the 
element name. 

Attachment Element 
Element that signifies an attachment. The type of content being attached is 
shown below the element name. 

Database Lookup Element 
Element that reads from a database. The method used to lookup the element 
in the database is shown after the element name.
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Quick Start
E-Mail

The following example will familiarize you with eDIRECT and demonstrate how to 
easily send merged output to a specified e-mail address using eDIRECT.

Once eFORMz has been installed on your PC start the eFORMz Composer:

1. From your Start Menu select Programs > eFORMz 9 > eFORMz Composer:

2. The eFORMz Composer window will display.

3. From the File Menu select File > Open Project.

4. Open the sampstm1.efz project file located in the C:\Minisoft\eFORMz_6\Projects\
eDirect\Sample1 folder:

 

5. The sampstm1.efz project will appear in the Form and Data Viewer.
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6. Switch to the eDIRECT (or eDIRECT PLUS) tab.
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Configuring the E-Mail Output Destination
For our quick start example we will be sending all merged output as an email with a PDF 
file attachment. 

1. Right click in the Project window, highlight Add Output and select E-Mail.

 

2. Right click the E-Mail icon and choose the Add attachment option. 
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3. Select PDF from the Format drop-down menu. 

  

Options available:

Text
Attachment will be in text file format. 

HTML
Attachment will be in HTML format. 

PDF
Attachment will be in PDF format. 

eFORMz Document
Attachment will be in an eFORMz Document format. 

Color PCL
Attachment will be in PCL file format (color). 

PCL
Attachment will be in PCL file format (B/W). 

XML
Attachment will be in XML format. 

Zebra XML
Attachment will be in Zebra XML format. 
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TIFF
Attachment will be in TIFF format. 

PNG
Attachment will be in PNG format.

JPEG
Attachment will be in JPEG format.

GIF
Attachment will be in GIF format.

BMP
Attachment will be in BMP format.

AFP
Attachment will be in AFP format.

Postcript
Attachment will be in Postcript format.

ZPLII
Attachment will be in ZPL format.

NONE
No attachment will be included in the email. 

4. Switch to the File tab. Enter a value in the File name field or select a Variable.
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5. Right click the E-Mail and select Add provider > JavaMail. 

 

6. The Envelope tab of the JavaMail dialog box will display.
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 Element Options:

 SMTP Host
IP address or name of the email server that will be used to send the generated 
emails. By default this is a constant element. Port # can be included by adding a 
colon (hosting.companyname.com:2525) as the separator.

 From
An email address that designates who the email is from. By default this is a 
constant element.

 To
An email address that designates the recipient of the email. This can be a constant, 
bound, or database tag reference. 

 

TIP:  Multiple email addresses can be separated by a semicolon ( ; ), 
making sure a space separates the semicolon and the following 
email address. For example:

 JohnDoe@minisoft.com; JaneDoe@minisoft.com

 CC 
An email address for CC recipients. Multiple email addresses can be separated by a 
semicolon ( ; ).

 BCC
An email address for BCC recipients. Multiple email addresses can be separated by 
a semicolon ( ; ).

 Subject
The subject of the email. By default this is a constant element.
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 SMTP Options
For SMTP host authentication.

 

 

NOTE:  If real client and user email information is used, they will receive an 
email when the eDIRECT process is run. We suggest using your own 
email server and email address for testing purposes only.

7. When complete click OK.
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8. Right click the Content: (PDF) element and select Add Form(s). 

 

9. Choose the form that will be sent as a PDF attachment. 
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Run the eDIRECT Process
1. From the eFORMz Main Menu, select Run > Process w/eDIRECT.

 

2.  Check your email account.
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Fax

In this quick start example, we will be using eDIRECT to output all merged data and 
forms to a particular fax number. To send all merged output to a fax machine you 
will need a fax server. After setting up the fax server, note the configured header 
information, for example:

@@Number 123-456-7890@@

123-456-7890 is the number of the fax machine you would like to send your output to.

Note: Header information may vary between different fax servers.

The header information will be outputted by eDIRECT and directed to the fax server 
which will process the header information to send the merged output to the correct fax 
machine. To specify the header information in eDIRECT, follow these instructions:

1. From the eFORMz Composer window select the File menu > Open Project.

2. Open the sampstm1.efz project file located in the C:\Minisoft\eFORMz_6\Projects\
eDirect\Sample1 folder.

3. The sampstm1.efz project file appears in the Form and Data Viewer. Switch to the 
eDIRECT (or eDIRECT PLUS) tab.
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4. Right click in the Project window, highlight Add Output and select Fax.

 

5. Right click the Fax output destination and select Add job > to Printer. 

 

Job Options:

 to File
Acts as an input directory, putting all of the output files in a directory that is 
monitored by the fax server and then sent to the specified fax number accordingly. 
For more information, go to the Directing Output to a Fax Server section. 

 to Printer
Sends the output to the printer queue monitored by your fax server.
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6. The Print Output dialog box will display. To define the printer queue monitored by 
your fax server, select the browse button from the Printer field.

 

7. Choose the Fax option. 
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8. Enter the fax server header information in the Header field.

 

 For example:

 @@Number 123-456-7890@@

 Note: Header information may vary between different fax servers.

9. Click OK.
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10. Right click the Print to: element of the Fax output destination and select Add 
Form(s). 

 

11. Choose the form and click OK. 

  



eDIRECT 11

eDIRECT Module

Run the eDIRECT Process
1. From the eFORMz Composer select Run > Process w/eDIRECT:

 

2. To redirect Fax output to a specific folder or fax queue, see Chapter 9: Print 
Automation > Local Toolkit.
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Variable Reference
E-Mail

The following example will demonstrate how to take a tagged email address from the 
original data file and using eDIRECT distribute the email to the specified recipients:

1.  Start the eFORMz Composer.

2. From the File menu select File > Open Project.

3. The Open dialog box appears. Select the sampstm2.efz project file from the C:\
Minisoft\eFORMz_6\Projects\eDirect\Sample2\ directory.

4. Another dialog box will appear allowing you to select the associated data file 
(stmdata2.dat).

5. The sampstm2.efz project file displays.

 

6. From the Project window select the Replace function located under the emailtag 
variable.
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7. Using your mouse, right click and select Edit.

 

8. From the Replace dialog box enter your email address with the one indicated in the 
Constant field (“youraddress@companyname.com”):

 

 Once complete click OK. Your email address will appear in the Form and Data 
Viewer. 

9. From the Project window, switch to the eDIRECT (or eDIRECT PLUS) tab. 
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Configuring the Output Destination
In the following example, all merged output will be sent as an email attachment to the 
specified email address contained in the data file. If a page does not contain an email 
address, as do pages 3 and 4, eDIRECT will simply skip these pages for emailing and 
create a PDF file for later use.

1. Right click in the Project window and select Add Output > E-Mail. 

 

2. Right click the E-Mail icon and choose the Add attachment option.
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3. Select PDF from the Format drop-down menu.

  

4. Right click the E-Mail and select Add provider > JavaMail.
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5. The Envelope tab of the JavaMail dialog box will display. In the To field, select the 
Variable radio button and pick the emailtag variable from the drop-down menu.

 

6. Configure your email server IP address, sender (From), subject, and body. If CC and 
BCC are needed configure these also. Click OK. 

7. Right click the Content: (PDF) element and select Add Form(s).
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8. Select the form to be sent as a PDF attachment.

  

9. To ensure that only the output with an email address is sent as an attachment, right 
click E-Mail and select Add AND Condition > Is not equal to. 
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10. Select ‘nth’ occurrence of variable emailtag is not equal to an empty value. If the 
emailtag variable has no email address value, then an email attachment will not be 
sent. If the email address is contained in the data file, an email will be sent as an 
attached PDF file. Click OK. 

  

11. Add a print file process to create PDF files of pages that do not contain an email 
address. Right click in the Project window and select Add Output > Print. 
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12. Right click the Print icon and select Add job > to File. 

 

13. From the Format list, select PDF.
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14. Right click the Content: (PDF) and choose the Add Form(s) option. 

 

15. Pick the form and click OK. 
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16. Right click Print and select Add AND Condition > Is equal to. 

  

17. Select ‘nth’ occurrence of variable emailtag is equal to an empty value. If the 
emailtag variable has no email address value, then a PDF file will be generated. 
Click OK.
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Run the eDIRECT Process
1. From the eFORMz Composer select Run > Process w/eDIRECT.
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Fax

The following example will demonstrate how to take a tagged fax number from a data 
file and using eDIRECT, direct the merged output to a fax server:

1. From the eFORMz Composer select the File menu > Open Project.

2. The Open dialog box appears. Select the sampstm2.efz project file from the C:\
Minisoft\eFORMz_6\Projects\eDirect\Sample2\ directory.

3. If a data file has not already been selected the Data File dialog box will display. 
Select the data file pertaining to the project file, in this case stmdata2.dat.

4. The sampstm2.efz project file will display in the Project window.

 

5. A variable tag has been added to the project file tagging the fax number. To change 
the fax number, right click FaxTag and select Add Function > Replace.
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6. The Replace dialog box displays. In the Replace all occurrence of > Constant field 
enter the fax number displayed in the data file (360-111-1111).

 Enter the number you would like to replace the existing fax number with (with: > 
constant field).

 

 Once complete click OK.

7. From the Project window, right click FaxTag and select Edit.

8. The Variable dialog box displays. Uncheck Copy original data to output.

 

 Once complete, click OK.

9. The fax number will disappear from the Form and Data output window. To apply 
the new fax number to the Form and Data output create a new rule.

10. Right click FaxTag and select Add Rule > Place Text.



eDIRECT 25

eDIRECT Module

11. The Rule Properties dialog box displays. Enter a new rule name and click OK.

 

12. The Place Text dialog box displays. Keep the existing horizontal and vertical 
positioning and click OK.

 



26   eDIRECT

eDIRECT/eDIRECT+ Manual

13. The new fax number appears in the Form and Data Viewer.
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eDIRECT Tab
For our example we will be sending all merged output to a specified fax number 
contained in the data file. If using real data, the fax number could vary from page to 
page. To allow eFORMz to send the merged output to the different fax devices do the 
following:

1. Right click the form (sample_statement) and select Add Variable > By position.

 

2. Enter a name and click OK.

 



28   eDIRECT

eDIRECT/eDIRECT+ Manual

3. Right click the FaxHeader variable and select Add Function > Set Value.

  

4. Enter your fax header information, for example:

  @@Number  

 Note: Leave a space for where the fax number will normally appear.
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5. Right click FaxHeader and select Add Function > Concatenate.

 

6. Choose the FaxTag variable from the Variable drop-down menu. 
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7. Right click the FaxTag variable and select Add Function > Concatenate.

 

8. Enter the remainder of the fax header. Click OK. The FaxHeader will now contain 
the following: @@Number <FaxTag>@@.

  

9. From the Project window switch to the eDIRECT (or eDIRECT PLUS) tab.
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10. Right click in the Project window and select Add Output > Fax.

 

11. Right click the Fax output destination and select Add job > to Printer. 
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12.  In the Printer field, add the fax server print queue. In the Header field, select the 
FaxHeader variable from the drop-down menu. 
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13. Right click Print to: and select Add Form(s). 

 

14. Pick the appropriate form. Click OK.

 

       The Fax output destination now references the fully qualified Fax header, which 
references back to the fax tag placed within the project file. In this way, if a 
data file contains multiple fax numbers, merged output will be directed to the 
corresponding fax number.
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Run the eDIRECT Process
1.  From the eFORMz Composer select Run > Process w/eDIRECT:

 

       To redirect fax output to a specific folder monitored by your fax server, instead 
of Add job > to Printer, the user would select Add job > to File (See Step 11). See 
Chapter 9: Print Automation > Local Toolkit for more details.
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Directing Output to a Fax Server

When Fax output is specified in eDIRECT, eFORMz simply creates a merged print file 
(.prn) containing the fax header information in record 1 of the merged output. This 
header information is necessary for processing by a fax server. The merged print file 
is created in a subfolder ( \fax ) under the output directory which automatically gets 
created if one does not already exist.

There are two options available for processing the merged print file to a fax server:

1. If the fax server software can be configured to monitor a folder for the eFORMz 
merged print file, you can either have the fax server software monitor the output 
directory containing the subfolder for the fax output from eFORMz or using an 
‘external’ command redirect the output to a folder on the fax server using a MOVE 
command.

2. The other option is to instruct eFORMz to ‘PRINT’ the merged print file to the fax 
print queue. To do so, add a Print File post process command after the Process with 
eDIRECT entry. The Source Directory will be \fax folder and the File Selection field 
refers to the print files generated during the merge process. Please note that wild-
card entries are permitted.

  

  

TIP:  It is recommended to delete, rename, or move these files using a post 
process command after they have been processed by your fax server 
otherwise they will be transmitted over again.
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Advanced 
eDIRECT Features

♦ Sorting

♦ Attach Name Option

♦ SMTP Options

♦ PDF Encryption

♦ PDF Viewing

♦ Creating Dynamic Subfolders

♦ File Header and Trailer Options
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Sorting

Variable Group - E-Mail and Faxing
When eDIRECT processes e-mail addresses or fax numbers based on a reference within 
a data file or database, identical e-mail addresses or fax numbers are grouped together 
allowing for consolidated file attachments.

If, for example, purchase orders are being processed and the same e-mail address or 
fax number appears consecutively but pertains to a different purchase order number, 
the Sort tab from the Project Properties can then be used to separate these pages by 
purchase order number.

1. For example, add a variable that tags the PO Number within your data file.
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2. Right click the variable and select Add Function > Insert String. 

 

3. Enter a constant value at the beginning of the variable data. Click OK. 
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4. Right click the project and select Properties > Sort. 

  

5. From the Sort tab, select the New option. 
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6. The Sort Key will display. Choose the By variable option and pick the variable 
created earlier from the drop-down menu. Click OK. 

 

7. Select the Set Group button and click OK.

 

NOTE:  For more on the Sort feature, refer to the Sort section in the Project 
Properties portion of Ch. 3: eFORMz Composer Menus and Project 
Options.
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8. Switch to the eDIRECT (or eDIRECT PLUS) tab. Right click in the Project window 
and select Add Output > E-Mail. 

 

9. Right click the E-Mail and select Add provider > JavaMail.
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10. Enter information for the necessary fields. For the Subject field, select the variable 
created earlier from the drop-down menu. When complete, click OK.

 

11. Right click E-Mail and select Add attachment.
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12. Choose PDF and switch to the File tab. 

 

13. Select the variable created earlier for the File name. Click OK. 
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14. Right click Content: (PDF) and select Add Form(s).

 

15. Choose the appropriate form and click OK. 

 

16. From the eFORMz Main Menu, highlight Run and pick the Process w/eDIRECT 
option.When the process is implemented, a file containing multiple purchase 
orders will be split based on the Sort key that has been set in the Project Properties.
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Group Output 
eDIRECT output can be set to have the output grouped (which is the current default) 
or not grouped.  The selection is done with a check menu item on the popup menu for 
the output node. If checked, individual pages are consolidated into a single output file 
(print, email, fax).
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Attach Name Option

When a pdf file is created by eFORMz, by default, the project file name is attached to 
the corresponding pdf file. If, for example, purchase orders are being processed and 
they need the pdf file name to have the attached purchase order number, use the 
following procedure:

1.  Tag the appropriate field (i.e. purchase order number) using a variable within the 
eFORMz Composer.

2. Right click the variable and select Add Function > Insert String. 

 

3. Enter a constant value at the beginning of the variable data. Click OK. 
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4. Switch to the eDIRECT (or eDIRECT PLUS) tab. Right click in the Project window 
and select Add Output > E-Mail. 

 

5. Right click the E-Mail and select Add provider > JavaMail. 

 



48   eDIRECT

eDIRECT/eDIRECT+ Manual

6. Enter information for the necessary fields. For the Subject field, select the variable 
created earlier from the drop-down menu. When complete, click OK. 

 

7. Right click E-Mail and select Add attachment. 
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8. Choose PDF and switch to the File tab. 

 

9. Select the variable created earlier for the File name. Click OK. 

 



50   eDIRECT

eDIRECT/eDIRECT+ Manual

10. Right click Content: (PDF) and select Add Form(s).

 

11. Choose the appropriate form and click OK. 

 

12. From the eFORMz Main Menu, highlight Run and pick the Process w/eDIRECT 
option.
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SMTP Options

eFORMz allows you to enable Simple Mail Transfer Protocol (SMTP) within eDIRECT. In 
order for this option to function, the server used must support SMTP. 

Options include:

User and Password used if needed.

Importance sets the priority of the email. Options include normal, low, high.

Sensitivity sets the condition of the email. Options include none, personal, private, 
confidential.

There are three request options: Read receipt requested, Delivery status notice requested 
and Full delivery status notice requested.
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PDF Encryption

Encrypt your PDF documents in one of the following ways:

♦ Standard 40-bit

♦ Standard 128-bit

♦ AES 128-bit (Advanced Encryption Standard)

Implementing PDF Encryption
To implement PDF Encryption from eDIRECT:

1. Right click Content: (PDF) and select Edit > Format. 
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2. Select Options and edit the available encryption options.

 

3. The PDF Output Options dialog box will display:
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Encryption 
Options include Standard 40-bit, Standard 128-bit and AES 128-bit encryption. 
Encryption is used to enforce restrictions on your document. The permissions that can 
be granted or restricted depend on the strength of the encryption (40-bit vs. 128-bit). If 
you are using 40-bit encryption, every permission that has the remark 128-bit below is 
granted automatically. If you want to revoke these permissions, you need to use 128-bit 
encryption.

User Password
Refers to the ‘open password’.

Owner Password
Refers to the ‘permissions password’.

The maximum password length is 32 characters. You may enter 32 characters or more 
but only the first 32 characters will be taken into account. One or both of the passwords 
fields can be empty. If a user password is not specified, all users will be able to open the 
document without being prompted for a password, but the permissions and restrictions 
(if any) will remain in place.

For a higher level of encryption for your document, choose 128-bit key length and 
always set both passwords, using different strings and all 32 characters for each one. 
If a password you choose is shorter than 32 characters, it will be padded with default 
padding.

Allow Printing
(Default checked) Printing the document.

Allow Degraded Printing
(128-bit) Printing the document, lesser quality printout than Allow Printing.

Allow Modify Contents 
Modifying the contents—for example, changing page content, inserting or removing 
pages.

Allow Assembly
(128-bit) Inserting, removing, rotating pages and adding bookmarks are allowed. 
Contents of a page cannot be changed, unless All Modify Content is allowed.

Allow Copy 
(Default checked) Copying or extracting text and graphics from the document, including 
technologies such as screen readers or other accessibility devices.

Allow Screen Readers 
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(128-bit) Extracting text and graphics from document using an accessibility devices.

(Default checked) Allow Modify Annotations
Adding or modifying text annotations and interactive form fields.

(Default checked) Allow Fill In
(128-bit) Filling form fields; adding or modifying annotations only if Allow Modify 
Annotations is granted.
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PDF Viewing

To modify PDF viewing options for PDF documents:

1. Right click Content: (PDF) and select Edit > Format.

 

2. Select Options. 
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3. The PDF Output Options dialog box will display. Switch to the Viewer tab:

 

Page layout
The page layout to be used when the document is opened:  

Single page - Display one page at a time (default).  

One column - Display the pages in one column. 

Two columns, odd on the left - Display the pages in two columns, with odd-
numbered pages on the left. 

Two columns, odd on the right - Display the pages in two columns, with odd-
numbered pages on the right. 

Two pages, odd on the left - Display the pages two at a time, with odd-numbered 
pages on the left. 

Two pages, odd on the right - Display the pages two at a time, with odd-numbered 
pages on the right. 
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Page mode
Sets how the document should be displayed when opened:

None - Neither document outline, nor thumbnail images visible (default).  

Show Outlines - Document outline visible.   

Show Thumbnails -  Thumbnail images visible. 

Full screen -  Full-screen mode. No menu bar, window controls, or other windows 
will be visible.

Show tool bar 
Displays (or hides) the toolbar.

Show menu bar 
Displays (or hides) the menu bar.

Show window UI 
Displays (or hides) the window user interface.

Show menu bar 
Displays (or hides) the menu bar.

Resize window to fit page
Adjusts the window to fit the page.

Center window
Centers the window.

Display document title
Displays the title of the PDF document. 

Print scaling
The Default option scales the PDF to a printable area. 

Simplex/Duplex
Printing options include Simplex, Short Edge Duplex, and Long Edge Duplex. 
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Creating Dynamic Subfolders

Dynamic subfolders can be created in eDIRECT under the parent directories of Print, 
Fax, or E-Mail. Subfolders can be dynamically created using variables from within the 
project file, for example:

1.  Create a variable that references a data element from within your data file:
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2. Add a variable By position. 

 

3. Enter a name and click OK.
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4. Right click the variable and select Add Function > Concatenate.

 

5. Pick the variable created earlier that references the data element.
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6. Right click the variable created by position and select Add Function > Insert String.

 

7. Insert two forward slashes ( // ) to the end of the variable, followed by a constant 
value. The forward slashes indicate that the reference appearing before them is the 
dynamic folder reference. The constant value after the slashes will be the file name 
of the output. Click OK. 
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8. Switch to the eDIRECT (or eDIRECT PLUS) tab. Right click in the Project window 
and select Add Output > Print. 

 

9. Right click Print and select Add job > to File. 
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10. Choose the Format and switch the File tab. 

 

11. In the File name field, select the variable created earlier by position. Click OK. 
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12. Right click the Content icon and select Add Form(s). 

 

13. Pick the form and click OK. 

  

14. From the eFORMz Main Menu, navigate to Run and select Process w/eDIRECT. 
Check the project directory. For this example, the Print directory should now have a 
new folder based on the variable reference. The new folder should also contain the 
specified output. 
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File Header and Trailer Options

Using the File Header and Trailer option, custom code can be added to file output. 
For example, if PJL codes for stapling need to be added to the output file enter the 
beginning and ending PJL codes into the File Header and Trailer fields.
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eDIRECT+ Overview
eDIRECT+ Agent

The eDIRECT+ Agent is a service that runs on a server for email distribution and 
tracking. The eDIRECT+ Agent Service (communications,  maintenance, monitoring, 
and control) is composed of three functional units and a database:

♦ SMTP Send (Outbound Mail Transfer Agent)

♦ SMTP Receive (Inbound Mail Transfer Agent)

♦ SMTP Monitor (Relay agent for enhancement and tagging) 

♦ Mail Database (Persistent storage area)
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SMTP Send
The SMTP Send Service is used to transmit and track eFORMz/eDIRECT+ email 
messages to the appropriate destination. It periodically checks the message queue 
for messages to be acted upon. It will pass the message to a thread that sends the 
message.

SMTP Receive
The SMTP Receive Service listens for incoming SMTP messages. It will receive Delivery 
Status Notification (DSN) replies from messages that have been sent. It also supports 
the Response Tracking module inside eDIRECT+. 

SMTP Monitor
The SMTP Monitor Service is used to capture outgoing email messages for 
enhancement by an eFORMz project. It receives messages on an arbitrary port and then 
copies that data to a new file. 

Mail Database
The Mail Database is a JDBC accessible database that stores messages. Scripts are 
provided for both SQL Server and MySQL. 
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eDIRECT+ Agent 
Configuration

The eDIRECT+ Agent Configuration Application arranges the initial settings of the 
eDIRECT+ Agent service. To configure the eDIRECT+ Agent Configuration:

1. Run the  eDIRECT+ Agent Configuration application:

  C:\Minisoft\eFORMz_6\eDP_AgentConfig.exe

2. Once open, the eDIRECT+ Agent Configuration dialog box will display. Click OK to 
proceed.

  



70

eDIRECT+ Agent Manual

3. The default username is ‘minisoft’ and the default password is ‘password’ though 
both properties can be changed. To customize the values, set the Registered 
User entry key and the Registered Password entry key from the Configure 
Authentication menu option.
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Global Configuration

The Global Configuration sets whether the SMTP Monitor, SMTP Send and the SMTP 
Receive services will commence when the eDIRECT+ Agent is started.

1. From the eDIRECT+ Agent Configuration Menu, select the Global Configuration 
option.
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2. The Global Configuration dialog box will display.

 

Options:

Start SMTP Receive Server
When checked, this will listen for incoming email messages when the 
eDIRECT+ agent starts. (Inbound Mail Transfer Agent)

Start SMTP Send Server
When checked, this will monitor for queued messages when the eDIRECT+ 
agent starts. (Outbound Mail Transfer Agent)

Start SMTP Monitor
When checked, this will start the SMTP Monitor when the eDIRECT+ agent  
starts. (Relay agent for enhancement and tagging)
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SMTP Monitor Configuration

The SMTP Monitor is used to capture outgoing email messages for enhancement by an 
eFORMz project. It receives messages on an arbitrary port and then copies that data to 
a new file.

1. From the eDIRECT+ Agent Configuration Menu, select Global Configuration option.
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2. Set the SMTP Monitor to start by checking the Start SMTP Monitor option. Click 
OK to return to the eDIRECT+ Agent Configuration Menu.

 

3. Next, select the SMTP Monitor Configuration option.
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4. The SMTP Monitor Ports dialog box will display. Select Add to add a new port.

5. The SMTP Monitor Port Configuration dialog box will display.

  

Options:

Active  
Activates or deactivates the settings. Default is checked.

Name 
The name given to the configuration.

SMTP Port
The SMTP Port is associated with the IP address of the host and the Simple Mail 
Transfer Protocol used for communication.

SMTP Bind Address
The IP address on the server used for listening. The SMTP Monitor will listen on 
all available ports if no value is entered. This parameter is important on systems 
that use another mail server also listening on the configured port.

Mail Domain
An arbitrary text string used to identify this system to a mail client. It is used 
primarily for testing.
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Data Directory
The directory into which the received mail files will be stored.

Max Threads
Limit on the number of simultaneous receives (default 10).

Min Threads
Smallest number of receivers started (default 5).

Smart Host
Address and Port number of a mail server to which messages are forwarded if 
they do not match on one of the (regex-based) search strings. If the Smart Host 
parameter is blank, all messages are kept locally.

Match Strings
Strings using regular expressions (regex) to match on for local storage. Those 
messages that do not match are sent to the Smart Host.

Keep Copy
Option used to keep a local copy of messages that are sent to a Smart Host. 
Default is unchecked.
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6. Make any necessary changes to the fields. For example, in the Match Strings 
field, enter a regular expression to match on certain information, such as an email 
subject.

  

 

NOTE:  For help with regular expressions there are multiple resources that 
can be accessed online. A basic guide is provided in the Regular 
Expressions section of this manual. The string in this example would 
match the beginning of the line that contained the word ‘Subject’ 
followed by a blank space, then one or more instances of the word 
‘Dear’ and either a comma or colon after that. So if there is a subject 
line with the word dear, it will be matched and stored locally. Recall 
that if the Smart Host parameter is blank then all of the messages are 
kept locally.
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7. Click OK to proceed. To save the configuration, first select Return. From the menu, 
choose the Save configuration option. The default configuration will be updated.
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 By default the files being stored in the specified data directory will contain the 
extension .mbx. Once the .mbx files have been created and placed in the specified 
directory, the next step is to use the files for an eFORMz project file transformation.
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SMTP Send Configuration

The settings of the SMTP Send Service are mostly default values that are used when an 
eFORMz project file does not supply a value. It is used to transmit email messages to 
the appropriate destination.

1. From the eDIRECT+ Agent Configuration Menu, select the SMTP Send 
Configuration option.
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2. Set the SMTP Send Server to start by checking the Start SMTP Send Server option. 
Click OK to return to the eDIRECT+ Agent Configuration Menu.

 

3. Next, select the SMTP Send Configuration option.
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4. The SMTP Send Configuration dialog box will display.

 

 Options:

Server Address  
The Server Address is the default address of the SMTP server through which to 
send SMTP messages.

Port 
The default port of the SMTP server through which to SMTP messages are sent.

Max Threads  
Limit on the number of concurrent processes. More threads allow sending to 
continue while one thread is busy incurring little additional overhead.

Min Threads
Smallest number of concurrent processes.

User
The name of the user on the host server. It is used to authenticate the message 
that should be sent through the host server.
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Password 
The user password on the host server that is used to authenticate the message 
that should be sent through the host server.

Sender Address  
This is the default from address for messages. This is typically modified in an 
eFORMz project.

Test Recipients
Email address(es) used to test the transport.

Transport Host
The Transport Host is the name used with the remote, or recipient server in the 
SMTP conversation to identify the host server name.
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SMTP Receive Configuration

The SMTP Receive service primarily listens for incoming messages, such as Delivery 
Status Notifications. By extension, it also supports the Response Tracking module inside 
eDIRECT+.

1. From the eDIRECT+ Agent Configuration Menu, select the SMTP Receive 
Configuration option.
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2. Set the SMTP Receive Server to start by checking the Start SMTP Receive Server 
option. Click OK to return to the eDIRECT+ Agent Configuration Menu.

 



86

eDIRECT+ Agent Manual

3. Next, select the SMTP Receive Configuration option.
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4. The SMTP Receive Configuration dialog box will display.

 

 Options:

SMTP Ports
A port or ports on which to listen for new email messages.

Max Threads  
Limit on the number of concurrent processes. More threads allow receiving to 
continue while one thread is busy incurring little additional overhead.

Min Threads
Smallest number of concurrent processes.

Mail Domain
The server name that is reported to sending servers.

Recipients
List of valid recipient names for this service. Messages received that do not 
match any of the listed entries will be rejected and the host may be black listed.
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Temp Directory 
Refers to the location which stores message files for further processing or 
review.

Mail Database Connection Configuration

The Mail Database Connection implements a connection to a database for storing 
messages.

1. From the eDIRECT+ Agent Configuration Menu, select the Mail Database 
Connection Configuration option.
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2. The Database Connection Configuration dialog box will display.

 

 Options:

Database Class Name
The class name for the JDBC connection to be used. There are two configured 
connections: com.microsoft.sqlserver.jdbc.SQLServerDriver and com.mysql.
jdbc.Driver.

Connection String  
The JDBC connection string to the eDIRECT+ Agent Mail Database.

Use Jar File
The optional jar file name if the database class is not statically configured in 
eFORMz.

Properties Table
The Property, Value and Required fields are database connection properties 
that are returned from a successful connection test. 

Check Properties
This option will test the database connection and return the default properties 
if a connection can be made.
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3. Select a Database class name and enter a Connection string. If necessary, add a jar 
file with the User jar file browse button (...). Select Check properties to verify the 
connection.
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Mail Database Maintenance Configuration

The Mail Database Maintenance controls the background monitoring of the eDIRECT+ 
Agent Mail Database. It handles the disposition of messages that do not have a specific 
disposition defined.  

1. From the eDIRECT+ Agent Configuration Menu, select the Mail Database 
Maintenance Configuration option.
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2. The Database Maintenance Configuration dialog box will display.

 

 Options:

Check Interval (minutes)
This refers to the frequency that the database is checked for records that can be 
“cleaned.”

Bad Hosts 
A method to reduce spam. The SMTP Receive will stop accepting connections 
from a host that sends [threshold] messages to invalid recipients within the last 
[history] days.

Message Contexts
Mail transfer agent database table. 

Message Options
Mail transfer agent database table. 

Outbound Queue
Mail transfer agent database table. 
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User Access Configuration

The User Access Configuration enables additional users to be added to a particular 
eDIRECT+ Agent configuration.

1. From the eDIRECT+ Agent Configuration Menu, select the User Access 
Configuration option.
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2. The Users Configuration dialog box will display. Select the Add user option.

 

3. The User dialog box will display. Enter the relevant information and click Add to 
incorporate the new user.
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 Options:

Admin
This privilege allows the user to control, manage, and configure the eDIRECT+ 
Agent.

Control
This privilege is required for starting, stopping, or pausing services. 

Manage
A user with this privilege may manage the mail queue.

Configure Authentication

The Configure Authentication sets the user and password values for the Authentication 
dialog box.

1. From the eDIRECT+ Agent Configuration Menu, select the Configuration 
Authentication option.
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2. The Authentication Configuration dialog box will display. 
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Configure Logging

The Configure Logging option allows the user to set the logging activity for eDIRECT+ 
Agent processes. For more on eDIRECT+ Agent logging, and logging with the eFORMz 
9.0 suite of products, consult the Logging Mini-Manual.

Save Configuration

1. From the eDIRECT+ Agent Configuration Menu, select the Save Configuration 
option to save any changes made to the eDIRECT+ Agent Configuration.
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eDIRECT+ Agent  
Management

The eDIRECT+ Agent is the service that handles the sending and receipt of email 
messages. The service is normally a background process without a user visible 
component (i.e. Windows Service). The service may be started and stopped with the 
usual operating system controls. The use of the eDIRECT+ Agent Control Application 
allows for additional control and detailed monitoring of the service while it is running.
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Control Settings
1. To manage the eDIRECT+ Agent, run the eDIRECT+ Agent Control Application at 

C:\Minisoft\eFORMz_6\eDP_Control. 

2. Once open, the eDIRECT+ Agent Management dialog box will display. Click OK to 
proceed.
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3. Enter the Host address, User and Password. The default User is username and the 
default Password is password. These can be updated with the settings.xml file in 
the eFORMz directory (C:\Minisoft\eFORMz_6\settings.xml).
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Display the Status of the eDIRECT+ Agent
The Display the Status of the eDIRECT+ Agent window shows the state of the SMTP 
send and receive components. It also allows each component to be started and stopped 
individually.

1. From the eDIRECT+ Agent Management Menu, select the Display the Status of the 
eDIRECT+ Agent option.
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2. The eDIRECT+ Agent Status will display.

 

Options:

Send Service
The SMTP Send service reads the message queue and transports the emails to 
the recipient mail servers.

Receive Service
The SMTP receive service is used to identify and sort incoming email messages. 
It uses a variety of search techniques to determine which outgoing message is 
related to each received message. Received messages include delivery status 
notifications, vacation notices, replies, and other information regarding the 
recipient.

Status Window
Details used by Minisoft support, often used to optimize run-time parameters.
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Display the Status of the eDIRECT+ SMTP Monitor
The Display the Status of the eDIRECT+ SMTP Monitor window shows the status of the 
SMTP Monitor service. 

1. From the eDIRECT+ Agent Management Menu, select the Display the Status of the 
eDIRECT+ SMTP Monitor option.
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2. The eDIRECT+ Agent Status will display.

 

Options:

SMTP Monitor Service
Indicates whether the SMTP Monitor is running or not.
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Send an E-Mail
The Send an E-Mail option allows the user to provide values that will override the 
defaults set for the SMTP Send Service. These options are available in each instance of 
an eFORMz project.

1. From the eDIRECT+ Agent Management Menu, select the Send an E-Mail option.
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2. The Submit E-Mail dialog box will display. To edit the SMTP options, select the 
SMTP Options button in the bottom left of the screen.

 

Options:

From
An email address that designates who the email is from.

To
An email address that designates the recipient of the email.

CC
An email address for CC recipients.

BCC
An email address for BCC recipients.

Subject
The subject of the email.

Message
The body of the email.
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3. The SMTP Test Message Server dialog box will display.

 

Options:

SMTP Host
The SMTP Host refers to the address of the SMTP server through which the 
SMTP message is sent.

Port
The SMTP server port.

Authentication Required
If enabled, enter the user and password to connect to the SMTP Host.

Read Receipt Requested
When enabled, it will send Delivery Status Notification to the SMTP Receive 
stating that the message was read. The recipient may opt not to send the DSN.

Send Notification Requested
When enabled, it will send Delivery Status Notification to the SMTP Receive 
stating that the send notification was received. The recipient may opt not to 
send the DSN.
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Request Full Notification
When enabled, it will send Delivery Status Notification to the SMTP Receive 
stating that a full notification was received. The recipient may opt not to send 
the DSN.

Importance
Options include: Normal, High and Low.

Sensitivity
Options include: Normal, Personal, Private and Confidential.
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Query Messages
The Query Messages option allows

1. From the eDIRECT+ Agent Management Menu, select the Query Messages option.

 

2. The Query Messages dialog box will display.
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Options:

Message State
The message state to query. Options include n/a, sent, queued and sending. 

Recipient
Specifies the ‘TO:’ address to query. 

Subject Contains
Defines the subject to query. 
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Shutdown the eDIRECT+ Agent
1. To shut down the eDIRECT+ Agent, select the Shutdown the eDIRECT+ Agent 

option from the Menu.
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Appendices  

APPENDIX A: eDIRECT+ Agent Message 
Disposition Matrix

Messages are stored at the time that they are created. The amount of time they remain 
stored is configured as the disposition. There are several actions that can be taken on 
a stored message. The action(s) will occur related to the state that they are in and the 
length of time in that state. As an example, a message can be configured to be deleted 
seven days after a successful transmission. Message dispositions are configured from 
the eDIRECT+ tab of the eFORMz Composer:

Delivery Actions

The following list includes actions that may be taken on a message state.

Delete
The “Delete” action will remove the message from the Mail Database. 
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Notify
The “Notify” action can send a notification or a status history. 

Dispatch
The “Dispatch” action will return the message to eFORMz for further action. 

Dispositions

Listed below are possible states that could apply to a message. Changes to message 
states are where a disposition action can be configured to occur.

 

Queued
“Queued” is the initial state of messages when they are received by the eDIRECT+ 
Agent Service.

Sent
The “Sent” state is set for a message when the SMTP Send service receives a 
“successful” status from the recipient’s email server. 

Could not send
The “Could not send” state is set for a message when the SMTP Send service receives 
a “failure code 5xx” status from the recipient’s email server. This could also be set if the 
SMTP Send cannot be opened, if there is no MX record for the recipient’s domain or if 
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code 4xx delays are past the configured expiration time. 

Cannot deliver
After a message is sent, there may be a delayed reply from a mailer daemon in the 
recipient’s mail server chain. This occurs when an intermediate server accepts the 
message in a store-and-forward configuration but it unable to complete the send to 
the recipient’s inbox. While a “Cannot deliver” message could arrive at any time, it is 
commonly ignored if the message is in the Sent state for 24 hours. 

Delivered
This is a Delivery Status Notification (DSN) that will return a “Delivered” message. If 
configured, it is returned to the sender by the recipient’s local email server or client. 

Undelivered
This is a Delivery Status Notification (DSN) that will return an “Undelivered” message. If 
configured, it is returned to the sender by the recipient’s local email server or client. 

Read
This is a Delivery Status Notification (DSN) that will return a “Read” message. If 
configured, it is returned to the sender by the recipient’s local email server or client. 

Reply
A “Reply” message indicates that a message was received that had the message ID of a 
previously “Sent” message. 
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APPENDIX B: The SMTP Monitor & Regular 
Expressions

The following is a basic reference guide for using regular expressions, which are a 
standard way of finding text using character sequences. The SMTP Monitor processes 
regular expressions for matching strings. Data is examined and matched in accordance 
with the given specifications of a regular expression. The Text to XML preprocessor also 
makes use of regular expressions.

Regex Engine

The regex engine used is from the Java Class java.util.regex.Pattern. While the syntax of 
this class has remained unchanged from Java 1.4 through 7, using the documentation 
for the JRE that is being employed is recommended.

Anchors

Anchors specify a position in a string where a match must occur. An anchor that is used 
in a regular expression will not advance through the string or consume characters. 
Instead, it looks for a match in the specified position only. For example, ^ specifies that 
the match must start at the beginning of a line or string.

^
Start of a line

\A
Start of an input string

$
End of a line

\Z
End of an input string
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Character Classes

A character class defines a set of characters, any one of which could occur in an input 
string for a match to succeed.

\c
Control character

\s
White space

\S
Not white space.

\d
Digit.

\D
Not digit.

\w
Word.

\W
Not word.

Quantifiers

Quantifiers specify the number of instances a character or character class must be 
present in the input for a match to be found. Quantifiers can be greedy or lazy. Greedy 
quantifiers match as many occurrences of a particular pattern as possible. Appending 
the ? character to a quantifier makes it lazy, which will match as few occurrences as 
possible.

*
0 or more. Example: X* is X zero or more times

*?
0 or more (lazy)

+
1 or more

+?
1 or more (lazy)
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?
0 or 1

??
0 or 1 (lazy)

{}
Exact number. Example: {3} is exactly 3

{3,}
3 or more

{3,5}
3, 4 or 5

{3,5}?
3, 4 or 5 (lazy)

Special Characters

When the search for a match requires something more than a direct match on position, 
text or a digit, the pattern includes special characters. 

\
Escape character

\n
New line

\r
Carriage return

\t
Tab

\v
Vertical tab

\f
Form feed
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Ranges (Inclusive)

Grouping constructs capture the substrings of an input string, or a specified range from 
the string.

.
Any character except a new line (\n)

(a|b)
a or b. 

[...]
Group

[abc]
Range (a or b or c)

[^abc]
Not a or b or c

[a-q]
Letter between a and q

[A-Q]
Upper case letter between A and Q

[0-7]
Digit between 0 and 7

Sample Patterns

Listed here are some common regular expressions for matching strings with the SMTP 
Monitor. Note that all expressions are case-sensitive. 

(Subject) or Subject
This basic pattern will pick up any instance of the word ‘Subject.’
This is typically used to match the subject line string of an email confirmation 
or notification, which contains the word ‘Subject.’ The parentheses are optional 
but it is case-sensitive.

^Subject[:]( )+Your
If the subject line string contains ‘Subject: Your Order:’ this expression can be 
used to match the input. The expression states that the instance of Subject at 
the beginning of a string, followed by a colon, then a blank space and one or 
more instances of Your will be matched.
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.Subject[:]( )+Your
If the subject line text characters are not at the very beginning of a string, then 
simply replace the ‘^’ boundary marker with a ‘.’ grouping construct. 
This expression states that for any character except a new line that contains 
Subject, followed by a colon, then a blank space and one or more instances of 
Your will be matched. The subject line picked up contains ‘Subject: Your Order.”

.Order( )+Number[:]
This expression will match the input string for ‘Order Number:’ that represents 
the order number information. This regular expression will match any character 
except a new line that contains Order, followed by a blank space and one or 
more instances of Number, followed by a colon.

.00920I or .( )00920I
Often, both shipping and order confirmation files will have the same or a similar 
subject. In order to process them separately, the letter number code of each file 
can be matched. The first expression listed will pick up any character except a 
new line, followed by the constant letter code value. 
The second expression will pick up any character except a new line followed by 
a blank space and the constant value. This need only be used if there are mul-
tiple instances of the letter code in the data file, as the blank space will distin-
guish it from other instances.

^Subject[:]( )+Ship
If the subject line string contains ‘Subject: Ship Confirmation’ this expres-
sion can be used to match the input. The statement reads that the instance of 
Subject at the beginning of a string, followed by a colon, then a blank space and 
one or more instances of Ship will be matched. 

.Ship( )+To[:]
This statement will match ‘Ship To:’ in the input file. The expression will match 
any character except a new line that contains Ship, followed by a blank space 
and one or more instances of To, followed by a colon.

.[0-12]\d[/]
This statement will match a date in the input file with a short numerical format. 
An example might be 05/02/12. The expression matches any character except a 
new line that contains any digit from zero through 12, followed by the instance 
of a forward slash ‘/’ character.



120   eDIRECT+

eDIRECT/eDIRECT+ Manual

APPENDIX C: The SMTP Monitor & 
Processing .mbx Files 

The SMTP Monitor captures outgoing email messages and generates .mbx files that 
can be enhanced by an eFORMz assembly engine project. With .mbx files, however, 
there aren’t noticeable differences in naming conventions amongst various data files. 
In other words, .mbx shipping acknowledgements will have file names that resemble a 
.mbx backorder notification. For an eFORMz project to make the distinction and listen 
for the right file, a condition must be set within the project.

eFORMz Project Condition
1. Beginning with a shipping confirmation, add a condition to the eFORMz project by 

right clicking the project name and selecting Add AND Condition > Contains.
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2. The Data Condition dialog box will display. It is at this point a decision must be 
made to differentiate between .mbx data files. An element that is constant and 
unique to a particular file is necessary for this to occur. Often, the subject line of 
these files are different, and so that is commonly chosen. Letter number code is 
also different and unique to a given file, and so that is also a common choice. Both 
will be demonstrated below. 

 

The order confirmation below has a subject line of ‘Your Order: Z05990293000’ and 
a letter number of ‘00513Z’:
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The ship confirmation below has a subject line of ‘Subject: SHIP CONFIRMATION’ 
and a letter number of ‘00533Z’.

 

3. From the drop-down menu, select the variable that picks up the subject line 
information. 

 

4. Select the Constant option and enter a value that matches the subject line. 
Entering ‘SHIP’ should serve the purpose, as it need only contain that word to be 
matched. Ordinarily, order confirmations should not have the word ship in their 
subject line. Click OK.

  



eDIRECT+ 123

eDIRECT+ Appendices

 

NOTE:  Conditions are case-sensitive, so if the subject line contained the 
‘Subject: Ship Confirmation’ then the constant value of the condition 
would have to be ‘Ship’ in order to generate a match.

5. In the event that a subject line match cannot occur, a condition can be placed on 
letter number code. From the Data Condition dialog box, select the variable that 
contains the letter number information.

 

Then enter the letter number value as a constant.
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6. For the order confirmation project, the process is similar. Right click the project 
name and select Add AND Condition > Contains.

 

7. The Data Condition dialog box will display. From the drop-down menu, select the 
variable that picks up the subject line information.
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8. Enter a value that matches the subject line. Entering ‘Order’ will serve the purpose, 
as it need only contain that word to be matched. Ordinarily, order confirmations 
are the only messages that will have that word in their subject line. Recall that it is 
case-sensitive. Click OK.

  

9. If a subject line match cannot occur, a condition can be placed on letter number 
code. From the Data Condition dialog box, select the variable that contains the 
letter number information.
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Then enter the letter number value as a constant.

 

REMINDER: 

Each project that is processing .mbx files must have a condition set 
within it. The project needs only one condition, and the most common 
choices are either the subject line or the letter number code. 
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Configuring the Director Toolkit

The Director is where the eFORMz assembly engine monitors for an incoming data 
file. The eFORMz project identifies the data file and they are merged. eDIRECT+ is a 
post-process that emails this merged document. The following instructions serve as a 
guide for configuring the Director Toolkit to listen for .mbx files and sending emails with 
the eDIRECT+ Agent. For more on the Director, consult the Director Mini-Manual. 

1. From the eFORMz Composer main menu select Host Tools and choose the 
appropriate Toolkit. The Local Toolkit applies to Windows, the AS400 Toolkit is for 
AS400 and iSeries users and the Unix Toolkit is for Unix and its variants.

2. The Input directory is the directory where the output file resides. Wherever 
eDIRECT+ Agent has been configured to output the .mbx files will be the Input 
directory. Right click the Input directory and select Add File Selector.
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3. The File Selector determines which data files are picked up. Enter *.mbx* in the 
File Selection field. The asterisks are wildcard characters that will pick up zero 
or more instances of the characters ‘mbx’. In other words, all files with the .mbx 
extension will be picked up.

  

4. Right click the File Selection and select Add Processor > eFORMz.

 

5. From the browse button (...) adjacent to the Project field, locate the eFORMz 
project that will be merged with the .mbx files.
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6. To add another project, right click the File Selection and select Add Processor > 
eFORMz.

 

7. From the browse button (...) adjacent to the Project field, locate the eFORMz 
project that will be merged with the .mbx files. Continue adding eFORMz projects 
as necessary.

 

8. With projects configured to listen for .mbx files and be merged appropriately, the 
next step is to add the eDIRECT+ post-process for emailing these documents. Right 
click an eFORMz Project and select Add Output Process > Process w/eDIRECT 
PLUS. 

 

9. Specify the directory where the processed output will reside by choosing a 
directory from the system using the browse button (...). 
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10. Add the eDIRECT+ output process to any other projects by right clicking the project 
and selecting Add Output Process > Process w/eDIRECT PLUS.

  

11. Specify the directory where the processed output will reside by choosing a 
directory from the system using the browse button (...). 

 

12. The Director Toolkit Configuration is ready for processing.

 

APPENDIX D: Cascading Style Sheets (CSS)

Often, transactional emails make use of Cascading Style Sheets (CSS), which define 
how to display HTML elements. This ensures brand consistency, as the look of any 
event-triggered message will reflect the company identity associated with the website. 
eDIRECT PLUS lets businesses create documents fully furnished with their style sheets 
by referencing them in the Document Template. For more on using style sheets, consult 
the Cascading Style Sheets Part of the Document Template Mini-Manual.
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APPENDIX E: Configuring an E-Mail for 
Multiple Client Types 

Sending messages in both HTML and text format is a sound email practice. After all, 
not all recipients will be able to view HTML messages properly. Plain text emails, if 
formatted properly, will ensure that all emails will be viewed in the appropriate format. 
With eDIRECT PLUS, text and HTML emails can be built and sent automatically. 

Once an HTML email has been built with eDIRECT PLUS, to send a plain text message, 
the user must build it accordingly. This process is similar to the design of the HTML 
document, as plain text emails are also built using the Document Template and 
processed with eDIRECT PLUS. 
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1. Crafting a plain text email, like the HTML message, requires its own form. To 
incorporate another form, right click the Page and select Add Form. 

  

2. Choose the Blank option from the Source of Form field. 
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3. The Form Properties dialog box will display. Click OK to proceed. 

  

4. Right click the Blank form and select Add Document Component > Paragraph. 
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5. The Paragraph Properties dialog box will display. Adjust the Alignment and other 
fields as necessary. 

   

6. Right click the Paragraph and select Add text > Text value.
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7. Enter a value in Text field and click OK to continue. 

 

8. To see all of the plain text document, right click the Project and select Display 
Forms and Data.
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9. To edit the element, Right click it, highlight Edit and pick the appropriate option. 
For example, to change the margins, select Edit > Margins. 

 



eDIRECT+ 137

eDIRECT+ Appendices

10. To edit the element, Right click it, highlight Edit and pick the appropriate option. 
For example, to change the margins, select Edit > Margins.
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11. The element will be successfully updated. 

 

12. To add spaces, right click the Paragraph and select Add > Line Break. 
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13. Right click the Paragraph, highlight Add text and pick the Text value option. 

  

14. Enter a value in the Text field. 
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15. To add variable values to the plain text email, the user need only copy the variables 
created for the HTML message. Left click the Variables and hold the Ctrl key. Then 
drag the Variables to the plain text document. 

 

16. The variables will be available for placement in both the HTML and plain text 
messages. 
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17. To add one of these variables, right click the Paragraph and select Add text > 
Variable value. 

  

18. Choose the desired variable from the Variable drop down menu. 
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19. The variable will be placed. Continue adding document components until the email 
is deemed ready.
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APPENDIX F: Cross-Selling and Upselling

Cross-selling and upselling are suggestive techniques designed to boost sales. Both 
methods match customers with additional products or services that might fit their 
needs, at the moment of a given purchase. Upselling is the practice of encouraging 
a client to buy an enhanced version of the product, or a related item that is more 
expensive. Cross-selling refers to the process of selling a complementary product 
or service. While effective at increasing revenue, cross-selling and upselling 
also strengthen existing customer relationships and contribute to their overall 
satisfaction. Minisoft’s eDIRECT PLUS can incorporate relevant upsell and cross-
sell offers.
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Dynamic

Configuring the Database
As numerous items could be shown for a particular product purchased, a database must 
be configured so that the dynamic information can be called with eDIRECT PLUS. While 
this information may be considered static, changing only periodically, the information 
referenced from the database will be plugged into Variables. This ensures that the latest 
updates from the database are automatically called.

Create a database with the necessary information. This may include the URL for an 
image, heading information and a link to the product’s page on the website:

1. Right click the Project and select Properties > Databases. 
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2. To add a new configuration, select the New option. 

  

 

NOTE:  eDIRECT PLUS supports many databases. Some of these include 
SQL Server, My SQL, Access, Oracle, Image, Eloquence, Progress, 
Sybase, DB2 (iSeries) and Informix.
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3. To edit the existing SQL Server database configuration, highlight it and select Edit.

   

4. Right click the Form and select Add Variable > By position.
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5. Name the Variable. This “InputData” Variable will act as the parameter for the SQL 
or Table Lookup. 
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6. Right click the Variable and select Add Function > Bulk Concatenate.

  

7. Select a Variable from the drop-down menu that contains Item Number 
information.
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8. Right click the InputData Variable and select Add Function > Right trim.

 

9. The InputData Variable will now contain each instance of an Item Number from a 
given order.
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10. Right click the Form and select Add Variable > By position.

 

11. Name the Variable so that it represents the Image (IP_1 in this example) column 
from the database.
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12. Continue adding Variables By position to represent each of the columns from the 
database. Right click one of these Variables (such as IP_1) and select Add Function 
> SQL Lookup.
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13. In the SQL Statement field, enter the statement as a Constant value or select a 
Variable which contains the statement. In the Parameters field, select the Add 
button and pick the InputData Variable created earlier. In the Additional columns 
assigned to field, select the Add button and choose all of the Variables that 
represent columns in the table that is being referenced in the SQL statement. 

 

 

NOTE:  A typical SELECT statement to return a column from a table is as 
follows: SELECT column_name(s) FROM table_name. Selecting all 
columns will require the SELECT * FROM table_name format. A 
stored procedure may also be referenced using an EXECUTE (EXEC) 
statement.
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14. In the Variables Window in the bottom left of the Composer, all of the column 
Variables will be picking up the information from the database.
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Links 

1. To incorporate the product Link from the database, right click the Paragraph 
component and select Add > Link.

  

2. Select the Variable that references the column containing links to product pages 
(URL_1 in this example). Click OK and repeat the process for additional URL column 
references.
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Images

1. To incorporate the Image from the database, right click the Link and select Add 
image > Image from URL using variable. 

 

2. Select the Variable that contains the Image URL. Click OK and repeat the process 
for adding other Image columns.
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Headings

1. To incorporate the Heading information from the database, right click the 
Paragraph Component and select Add text > Variable value.

  

2. Select the Variable that contains the Heading value. Click OK and repeat the 
process for adding other Heading columns.
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Static

Link
Static offers, which refer to proposals which do not make calls to a database, utilize 
linked information or constant values. Often, this information is displayed conditionally.

1. To add a Link to a particular product, right click the Paragraph component and 
select Add > Link.

  

2. Enter the URL for the product’s page in the Link field.
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Image from URL
1. To add an Image of a particular product to the Link, right click the Link and select 

Add image > Image from URL.

 

2. Enter the URL for the Image in the Image from URL field.
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Text Value
1. To add descriptions of a particular product, right click the Paragraph component 

and select Add text > Text value.

 

2. Enter a value for the Text field that describes the product. Click OK to complete.
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Conditional Logic Language
To display certain products conditionally, by day of the week for example, Conditional 
Logic Language is employed.

1. To conditionally place a product based upon the day of the week, create a Variable 
By position that will act as the weekday reference. 

  

2. Right click the Variable and select Add Function > Set value.

  

3. Select the Current Day of Week (Numeric) System variable from the Variable 
drop-down menu.
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4. Right click the Image and select Add AND Condition > Is equal to.

 

5. Select the Weekday Variable and enter a Constant value of 1. This will ensure that 
the Image will display if nth instance of the Weekday Variable is equal to the first 
day of the week.

 

6. To add another Condition, right click the Condition Group and select Add 
Conditions > Is equal to.
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7. Select the Weekday Variable from the drop-down menu and then enter 3 as the 
Constant value. If nth instance of the Weekday Variable is equal to the third day of 
the week, then the Image will also display.

 

8. If it is the first or third day of the week, then this particular image will display. It will 
not display on other days of the week.
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APPENDIX G: Response Tracking

Response measurement is a way to analyze marketing performance in order to make 
more informed business decisions. When sending an email with eDIRECT+, add a 
response tracker to a link or image to verify how much traffic it generated. 

Response tracking of emails requires four components:

• The eDIRECT+ Agent

• The Web Server

• The Mail Database

• An email containing the tracking information

The SMTP Receive service (Inbound Mail Transfer Agent), which primarily listens for 
incoming messages such as Delivery Status Notifications, also supports the Response 
Tracking module inside eDIRECT+ in the event of a reply to an email or a returned 
Delivery Status Notification such as a read receipt.
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To enable response tracking, eFORMz monitors a directory where specified output 
resides, and then picks up the data and merges it with an HTML document designed 
with the eFORMz Composer. Within the eFORMz Composer, there are two standard 
trackers that can then be configured: eDIRECT PLUS Agent - Read Tracking and eDIRECT 
PLUS Agent - Click Tracking. Read tracking determines if the email was read and counts 
opens. For example, an image on an email could have read tracking configured for 
it to count how many times that email was read. Click tracking counts the number 
of clicks for a link. For example, a link on a transactional email could have response 
tracking configured to determine if the recipient clicked on that link. Once trackers are 
configured, the email can be sent. The eDIRECT+ Agent sends an SMTP email to the 
recipient, which is then opened. Once opened, responses are sent to the Web Server, 
which counts responses. There are two kinds of responses. One is a request for an 
image and the other is a request to go to a link. When the Web Server receives a request 
for an image, it counts the event and then responds with the requested image. When it 
receives a request to go to a link it counts the event and responds by redirecting to the 
link.  

The Web Server’s default context (the part after the address and port in the url) is 
“tracking”. It takes 2 parameters which are “ContentId” and “CounterId”. ContentId 
is generated when the email is originally sent. CounterId is user-defined. The context 
is used to create a table in the Mail Database that keeps the counts. One table is built 
for each tracking context to count responses. The table, ‘TrackingContexts’ contains 
the ContentId of the email, the CounterId, the date/time of first response, the data/
time of last response, and the response count. The columns are as follows: ContentId, 
CounterId, first_count, last_update and counter. Analysis of response tracking data 
is done by querying this table with a third party reporting tool, such as SQL Server 
Reporting Services.

NOTE:  Other configurations can be used to support third party response 
tracking servers. Contact Minisoft support for more information at 
support@minisoft.com or (800)682-0200.
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Configuring an Email for Response Tracking

For configuring an email for response tracking, a tracker can be put on either image 
content or links inside of a Document Template. Response tracking configured for an 
image will cause a request to the server every time that image is displayed. This can be 
used to count when and how many times an email is read. eDIRECT PLUS Agent - Read 
Tracking would be used in this situation. Response tracking configured for a link will 
cause a request to the server every time that link is clicked, counting the number of 
clicks the link receives. eDIRECT PLUS Agent - Click Tracking would be used in this 
situation. Typically, each image and/or link that has response tracking configured will 
use a different “CounterId” so the specific event can be counted.

To configure an image on a transactional email for eDIRECT PLUS Agent - Read Tracking, 
right click the image and select Edit > Response Tracking.
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The Content Segment Properties dialog box will display. Select eDIRECT PLUS Agent - 
Read Tracking from the drop-down menu. Next, enter a constant value for the ContentId 
parameter, or select a variable value from the drop-down menu. 

TIP:  In addition to the image and the email, the CounterId can identify the 
recipient. To do this, the CounterId would have to contain information 
on the customer and/or the product. Using a variable value that has 
the subject line, the order confirmation number or the product item 
number data could fulfill this requirement.

A link on a transactional email could have response tracking configured to determine 
if the recipient clicked on a link. To configure an image on a transactional email for 
eDIRECT PLUS Agent - Click Tracking, right click the image and select Edit > Response 
Tracking.
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The Content Segment Properties dialog box will display. Select eDIRECT PLUS Agent - 
Click Tracking from the drop-down menu. Next, enter a constant value for the ContentId 
parameter, or select a variable value from the drop-down menu.

 

TIP:  In addition to the link and the email, the CounterId can identify the 
recipient. To do this, the CounterId would have to contain information 
on the customer and/or the product. Using a variable value that has 
the subject line, the order confirmation number or the product item 
number data could fulfill this requirement. For example, if the link in 
the email was to a web page for a specific product, the proper naming 
of the CounterId could show if the email prompted anyone to look at 
the product and also if the product was ordered by anyone reading the 
email. The data analysis would consist of comparing the responses for 
the link to the orders for the product.
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Querying Results

To retrieve the counter information, the ‘TrackingContexts’ table must be queried. 
For example, as shown above, ‘Subject_OrderConfirmation’ was the value for 
ContentId. So, using a SELECT * FROM TrackingContexts WHERE CounterId 
=‘Subject_OrderConfirmation’ will show all of the counting results.  

These are the tables created and used by the eDIRECT PLUS Agent for response 
tracking:

TrackingContexts
Contains a row for each tracking context, which contains the context name and 
a count of the number of emails sent that use that tracking context.

RT_<tracking context name>
One table is built for each tracking context to count responses. The table con-
tains the contentID of the email, the counterID, date/time of first response, data/
time of last response, and the response count.
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APPENDIX H: SMS Gateway Configuration

Short Message Service (SMS) is a text messaging service that enables the sending 
and receiving of messages between mobile phones. A text message can include 160 
characters if 7-bit character encoding (Latin characters) is used or 70 characters if 16-bit 
Unicode UCS2 character encoding is used (non-Latin characters such as Chinese). 
Sending SMS text messages requires the eFORMz Assembly Engine, the eDIRECT+ 
SMS Gateway and an SMS Provider. 

Configuring the eFORMz Project
The eFORMz Assembly Engine monitors a directory for incoming data generated by a 
software application and then merges that data with a form or document to be printed, 
faxed, emailed, archived or outputted as a file. A portion of this data can also be sent as 
a text message with the eDIRECT+ SMS Gateway process.

1. To configure the eFORMz Assembly Engine, select File > New Project from the 
eFORMz Composer.
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2. Right click the Project and select Add Page.

 

3. Select OK to proceed. 
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4. Right click the Page and choose the Add Form option.

  

5. Pick the Blank option. 
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6. The Form Properties dialog box will display. Click OK to continue. 

  

7. Right click the Project and select Display Forms and Data. 
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8. Choose the From file option. 

  

9. Find and open the appropriate data file.
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10. The Blank Form and data file will display in the eFORMz Composer.

 

11. In the top right Viewer window pane, the incoming data from the file will be 
showing. To take some portion of this file for use in a text message, a Variable can 
be created.  Left mouse click and drag a given string of characters, then right click 
and select Add Variable.
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12. The Variable dialog box will display. Enter a name and click OK to continue.
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13. Repeat the process with any other desired information from the data file. 

 

 

14. To add information from a database lookup, such as a phone number, Right click 
the Form and select Add Variable > By position. 
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15. The Variable dialog box will display. Enter a name and click OK to proceed.

  

16. Right click the Variable and select Add Function > SQL Lookup.
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17. Select the Database, enter an SQL Statement and assign any Parameters or 
Columns as necessary to return the necessary information. 

 

 

NOTE:  To add a database, right click the Project and select Properties 
> Databases. For more on databases, see the Table Lookup and 
SQL Lookup parts of the Variable Functions section of Chapter 5: 
eFORMz Composer Data Customization in the eFORMz/eDIRECT 
Manual. This is available online at: http://www.minisoft.com/pages/
general/manuals/manuals.html
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18. For purposes of testing, setting the Variable that returns database information as 
a constant phone number is recommended. Right click the Variable and select Add 
Function > Set Value.

 

19. Enter a test phone number in the Value field as a Constant.
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Sending the Text Message

Processing w/eDIRECT+
To send the text message:

1. From the Project window, switch to the eDIRECT PLUS tab. Right click in the 
window and select Add Output > SMS.
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2. Right click the SMS icon and select Add Provider > CDYNE SMS. 

 

 

NOTE:  Minisoft recommends three SMS Providers: CDYNE (http://www.
cdyne.com/), DialMyCalls (http://www.dialmycalls.com/) and 
SendHub (https://www.sendhub.com/). To learn more about the 
listed recommendations, it is suggested that their websites be 
visited for comparison purposes. If a different third party SMS 
Provider is being used, contact our support team at support@
minisoft.com.
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3. The CDYNE SMS dialog box will display. In the Number field, select the Variable 
that contains or returns the phone number information. 

  

4. In the Message field, select the Variable that contains or returns the message to be 
sent or enter a Constant value.
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5. Enter the URL and the API Key provided by the SMS Provider in their respective 
fields. Click OK when complete.

 

6. Navigate to the eFORMz Main Menu and select Run > Process w/eDIRECT PLUS.
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7. The SMS text message will be sent.
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